Platform Support

docxtemplater works with

  • Node.js versions 0.10, 0.11, 0.12 and io.js
  • Chrome tested on version 26
  • Firefox 3+ (tested on version 21, but should work with 3+)
  • Safari tested
  • IE9+ tested
  • Android 4.2+ tested
  • iPads and iPhones v8.1 tested

You can test if everything works fine on your browser by using the test runner: http://javascript-ninja.fr/docxtemplater/v1/test/SpecRunner.html

Dependencies

  1. docxgen.js uses [jszip.js](http://stuk.github.io/jszip/) to zip and unzip the docx files