Platform Support

docxtemplater works on most modern platforms, and also some older ones. Here is a list of what is tested regularly:

  • Node.js versions 6, 7, 8, 9, 10, 11, 12 and all future versions (older versions will also work, but support has ended)
  • Chrome version 58,71,73
  • Firefox 55,60,66
  • Safari 11,12
  • IE10, IE11, Edge 16-18
  • Android 4.2+
  • iPads and iPhones v8.1, 10.3

Dependencies

  1. PizZip to zip and unzip the docx files
  2. xmldom to parse the files as xml